# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(in)(?=\s*\d+)|' time"
test_str = ("2014/12/04 Test in 1 day' time 0 weeks\n"
"2014/12/07 Amazon Prime Ends in 95 days | 13 weeks\n"
"2014/12/24 Christmas in China in 112 days | 16 weeks")
subst = "|"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.