$re = '/(in)(?=\s*\d+)|\' time/';
$str = '2014/12/04 Test in 1 day\' time 0 weeks
2014/12/07 Amazon Prime Ends in 95 days | 13 weeks
2014/12/24 Christmas in China in 112 days | 16 weeks';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;