package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9][0-9][0-9]$|^[1][0-9][0-9][0-9]$`)
var str = `99
100
123
200
500
999
1000
1234
1500
1999
2000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}