import re
regex = re.compile(r"^[1-9][0-9][0-9]$|^[1][0-9][0-9][0-9]$", flags=re.MULTILINE)
test_str = ("99\n"
"100\n"
"123\n"
"200\n"
"500\n"
"999\n"
"1000\n"
"1234\n"
"1500\n"
"1999\n"
"2000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")