$re = '/^[1-9][0-9][0-9]$|^[1][0-9][0-9][0-9]$/m';
$str = '99
100
123
200
500
999
1000
1234
1500
1999
2000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);