# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{1})(.{2})(.{1})(.{2})(.{1})(.{1})(.{1})-(.+)/$1-$2-$4-$5-$6-$7\/$1$2$3$4$5$6$7-$8/gm;t' <<< "M34027Bb3-SH10150.jpg"