import re
regex = re.compile(r"^(.{1})(.{2})(.{1})(.{2})(.{1})(.{1})(.{1})-(.+)", flags=re.MULTILINE)
test_str = "M34027Bb3-SH10150.jpg"
subst = "$1-$2-$4-$5-$6-$7/$1$2$3$4$5$6$7-$8"
result = regex.sub(subst, test_str)
if result:
print(result)