const regex = /^(.{1})(.{2})(.{1})(.{2})(.{1})(.{1})(.{1})-(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{1})(.{2})(.{1})(.{2})(.{1})(.{1})(.{1})-(.+)', 'gm')
const str = `M34027Bb3-SH10150.jpg`;
const subst = `$1-$2-$4-$5-$6-$7/$1$2$3$4$5$6$7-$8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);