$re = '/^(.{1})(.{2})(.{1})(.{2})(.{1})(.{1})(.{1})-(.+)/m';
$str = 'M34027Bb3-SH10150.jpg';
$subst = "$1-$2-$4-$5-$6-$7/$1$2$3$4$5$6$7-$8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;