const regex = /^i=\d+(?:&s\d+=\d+(?=&|$))+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^i=\\d+(?:&s\\d+=\\d+(?=&|$))+$', 'mg')
const str = `i=1&s1=122&s2=238&s3=167&s4=756&s5=13`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}