import re
regex = re.compile(r"^i=\d+(?:&s\d+=\d+(?=&|$))+$", flags=re.MULTILINE)
test_str = "i=1&s1=122&s2=238&s3=167&s4=756&s5=13"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")