$re = '/^i=\d+(?:&s\d+=\d+(?=&|$))+$/m';
$str = 'i=1&s1=122&s2=238&s3=167&s4=756&s5=13';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);