re = /^i=\d+(?:&s\d+=\d+(?=&|$))+$/m
str = 'i=1&s1=122&s2=238&s3=167&s4=756&s5=13'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end