# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:Hornet|Valiant)(*SKIP)(*F)|(\h*+)(.+)/\1*\2*/gm;t' <<< "Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant"