// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:Hornet|Valiant)(*SKIP)(*F)|(\h*+)(.+)").unwrap();
let string = "Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant";
let substitution = "\\1*\\2*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}