#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:Hornet|Valiant)(*SKIP)(*F)|(\h*+)(.+)"
Local $sString = "Mazda RX4" & @CRLF & _
"Mazda RX4 Wag" & @CRLF & _
"Datsun 710" & @CRLF & _
"Hornet 4 Drive" & @CRLF & _
"Hornet Sportabout" & @CRLF & _
"Valiant"
Local $sSubst = "\1*\2*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)