import Foundation
let pattern = #"^(?:Hornet|Valiant)(*SKIP)(*F)|(\h*+)(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1*\2*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)