import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p(.*?)>(.+?)<\\/p\\>";
final String string = " <tr style=\"vertical-align: top; text-align: left; padding: 0;\" align=\"\">\n"
+ " <td class=\"\" style=\"word-break: break-word; -webkit-hyphens: auto; -moz-hyphens: auto; hyphens: auto; border-collapse: collapse !important; vertical-align: top; text-align: left; color: #002045; font-family: Arial, sans-serif, Helvetica; font-weight: normal; line-height: 16px; font-size: 12px; margin: 0; padding: 0;\" align=\"left\" valign=\"top\"><p>Dear Name Name,<br>\n"
+ " <br>\n"
+ " Thank you for being awsome <strong> in here</strong>.<br>\n"
+ " <br>\n"
+ " Your opinion is very important to us.</p>\n"
+ " </td>\n"
+ " </tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}