use strict;
my $str = ' <tr style="vertical-align: top; text-align: left; padding: 0;" align="">
<td class="" style="word-break: break-word; -webkit-hyphens: auto; -moz-hyphens: auto; hyphens: auto; border-collapse: collapse !important; vertical-align: top; text-align: left; color: #002045; font-family: Arial, sans-serif, Helvetica; font-weight: normal; line-height: 16px; font-size: 12px; margin: 0; padding: 0;" align="left" valign="top"><p>Dear Name Name,<br>
<br>
Thank you for being awsome <strong> in here</strong>.<br>
<br>
Your opinion is very important to us.</p>
</td>
</tr>';
my $regex = qr/<p(.*?)>(.+?)<\/p\>/imsp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}