// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ims)<p(.*?)>(.+?)<\/p\>").unwrap();
let string = " <tr style=\"vertical-align: top; text-align: left; padding: 0;\" align=\"\">
<td class=\"\" style=\"word-break: break-word; -webkit-hyphens: auto; -moz-hyphens: auto; hyphens: auto; border-collapse: collapse !important; vertical-align: top; text-align: left; color: #002045; font-family: Arial, sans-serif, Helvetica; font-weight: normal; line-height: 16px; font-size: 12px; margin: 0; padding: 0;\" align=\"left\" valign=\"top\"><p>Dear Name Name,<br>
<br>
Thank you for being awsome <strong> in here</strong>.<br>
<br>
Your opinion is very important to us.</p>
</td>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}