# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<p(.*?)>(.+?)<\/p\>"
test_str = (" <tr style=\"vertical-align: top; text-align: left; padding: 0;\" align=\"\">\n"
" <td class=\"\" style=\"word-break: break-word; -webkit-hyphens: auto; -moz-hyphens: auto; hyphens: auto; border-collapse: collapse !important; vertical-align: top; text-align: left; color: #002045; font-family: Arial, sans-serif, Helvetica; font-weight: normal; line-height: 16px; font-size: 12px; margin: 0; padding: 0;\" align=\"left\" valign=\"top\"><p>Dear Name Name,<br>\n"
" <br>\n"
" Thank you for being awsome <strong> in here</strong>.<br>\n"
" <br>\n"
" Your opinion is very important to us.</p>\n"
" </td>\n"
" </tr>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.