#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SPECGRID.*\n([\s\S]*?)\/"
Local $sString = "MAPAXES -- Generated : Petrel" & @CRLF & _
" 159589.61 7782837.94 159589.61 7783837.94 160589.61 7783837.94 /" & @CRLF & _
"" & @CRLF & _
"GRIDUNIT -- Generated : Petrel" & @CRLF & _
" METRES /" & @CRLF & _
"" & @CRLF & _
"SPECGRID -- Generated : Petrel" & @CRLF & _
" 3 26 120 1 F /" & @CRLF & _
"" & @CRLF & _
"COORDSYS -- Generated : Petrel" & @CRLF & _
" 1 120 /" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")