package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SPECGRID.*\n([\s\S]*?)\/`)
var str = `MAPAXES -- Generated : Petrel
159589.61 7782837.94 159589.61 7783837.94 160589.61 7783837.94 /
GRIDUNIT -- Generated : Petrel
METRES /
SPECGRID -- Generated : Petrel
3 26 120 1 F /
COORDSYS -- Generated : Petrel
1 120 /
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}