$re = '/SPECGRID.*\n([\s\S]*?)\//';
$str = 'MAPAXES -- Generated : Petrel
159589.61 7782837.94 159589.61 7783837.94 160589.61 7783837.94 /
GRIDUNIT -- Generated : Petrel
METRES /
SPECGRID -- Generated : Petrel
3 26 120 1 F /
COORDSYS -- Generated : Petrel
1 120 /
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);