#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)@Layout(?:(?!@Layout).)*"
Local $sString = "import com.myCompanyExample.gui.Layout" & @CRLF & _
"" & @CRLF & _
"/*some comments here*/" & @CRLF & _
"" & @CRLF & _
"@Layout" & @CRLF & _
"LayoutModel currentState() {" & @CRLF & _
" MyBuilder builder = new MyBuilder()" & @CRLF & _
" form example" & @CRLF & _
" title form{" & @CRLF & _
" row_1" & @CRLF & _
" row_1 " & @CRLF & _
" row_n" & @CRLF & _
" }" & @CRLF & _
" return build.get()" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@Layout" & @CRLF & _
"LayoutModel otherState() {" & @CRLF & _
" ...." & @CRLF & _
" ...." & @CRLF & _
" return build.get()" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")