import re
regex = re.compile(r"@Layout(?:(?!@Layout).)*", flags=re.DOTALL)
test_str = ("import com.myCompanyExample.gui.Layout\n\n"
"/*some comments here*/\n\n"
"@Layout\n"
"LayoutModel currentState() {\n"
" MyBuilder builder = new MyBuilder()\n"
" form example\n"
" title form{\n"
" row_1\n"
" row_1 \n"
" row_n\n"
" }\n"
" return build.get()\n"
"}\n\n"
"@Layout\n"
"LayoutModel otherState() {\n"
" ....\n"
" ....\n"
" return build.get()\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")