re = /@Layout(?:(?!@Layout).)*/
str = 'import com.myCompanyExample.gui.Layout
/*some comments here*/
@Layout
LayoutModel currentState() {
MyBuilder builder = new MyBuilder()
form example
title form{
row_1
row_1
row_n
}
return build.get()
}
@Layout
LayoutModel otherState() {
....
....
return build.get()
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end