import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@Layout(?:(?!@Layout).)*";
final String string = "import com.myCompanyExample.gui.Layout\n\n"
+ "/*some comments here*/\n\n"
+ "@Layout\n"
+ "LayoutModel currentState() {\n"
+ " MyBuilder builder = new MyBuilder()\n"
+ " form example\n"
+ " title form{\n"
+ " row_1\n"
+ " row_1 \n"
+ " row_n\n"
+ " }\n"
+ " return build.get()\n"
+ "}\n\n"
+ "@Layout\n"
+ "LayoutModel otherState() {\n"
+ " ....\n"
+ " ....\n"
+ " return build.get()\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}