using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(?=((\\|\/).+){4})";
string input = @"C:\Change\the\number\2\to\anything\else\and\test\and\see\what\happens
C:\Users\Andrew\Desktop\Folder1\Folder2\Folder3\Folder4\file.txt
C:\ProgramData\Microsoft\Diagnosis\EventTranscript\EventTranscript.db
C:\Windows\System32\config\SAM
C:\Windows\System32\winevt\logs\Application.evtx
C:\Users\%user%\AppData\Local\Microsoft\Windows\Notifications\wpndatabase.db";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}