# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+(?=((\\|\/).+){4})"
test_str = ("C:\\Change\\the\\number\\2\\to\\anything\\else\\and\\test\\and\\see\\what\\happens\n"
"C:\\Users\\Andrew\\Desktop\\Folder1\\Folder2\\Folder3\\Folder4\\file.txt\n"
"C:\\ProgramData\\Microsoft\\Diagnosis\\EventTranscript\\EventTranscript.db\n"
"C:\\Windows\\System32\\config\\SAM\n"
"C:\\Windows\\System32\\winevt\\logs\\Application.evtx\n"
"C:\\Users\\%user%\\AppData\\Local\\Microsoft\\Windows\\Notifications\\wpndatabase.db")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.