const regex = /.+(?=((\\|\/).+){4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+(?=((\\\\|\\\/).+){4})', 'gm')
const str = `C:\\Change\\the\\number\\2\\to\\anything\\else\\and\\test\\and\\see\\what\\happens
C:\\Users\\Andrew\\Desktop\\Folder1\\Folder2\\Folder3\\Folder4\\file.txt
C:\\ProgramData\\Microsoft\\Diagnosis\\EventTranscript\\EventTranscript.db
C:\\Windows\\System32\\config\\SAM
C:\\Windows\\System32\\winevt\\logs\\Application.evtx
C:\\Users\\%user%\\AppData\\Local\\Microsoft\\Windows\\Notifications\\wpndatabase.db`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}