$re = '/.+(?=((\\\\|\/).+){4})/m';
$str = 'C:\\Change\\the\\number\\2\\to\\anything\\else\\and\\test\\and\\see\\what\\happens
C:\\Users\\Andrew\\Desktop\\Folder1\\Folder2\\Folder3\\Folder4\\file.txt
C:\\ProgramData\\Microsoft\\Diagnosis\\EventTranscript\\EventTranscript.db
C:\\Windows\\System32\\config\\SAM
C:\\Windows\\System32\\winevt\\logs\\Application.evtx
C:\\Users\\%user%\\AppData\\Local\\Microsoft\\Windows\\Notifications\\wpndatabase.db';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);