re = /(?:team\/([0-9]+))\/(?:project\/([0-9]+))\/(?:type\/([0-9]+))(.*)(?:assignee\/([0-9]+))\/(?:author\/([0-9]+))\/(.*?)(?:status\/current\/)/i
str = 'https://behappy.cayetano.bg/explore/team/9/project/60/type/1/version/0/assignee/219/author/219/status/current/order/date/group/status/editid/0/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end