// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:team\/([0-9]+))\/(?:project\/([0-9]+))\/(?:type\/([0-9]+))(.*)(?:assignee\/([0-9]+))\/(?:author\/([0-9]+))\/(.*?)(?:status\/current\/)").unwrap();
let string = "https://behappy.cayetano.bg/explore/team/9/project/60/type/1/version/0/assignee/219/author/219/status/current/order/date/group/status/editid/0/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}