import Foundation
let pattern = #"(?:team\/([0-9]+))\/(?:project\/([0-9]+))\/(?:type\/([0-9]+))(.*)(?:assignee\/([0-9]+))\/(?:author\/([0-9]+))\/(.*?)(?:status\/current\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"https://behappy.cayetano.bg/explore/team/9/project/60/type/1/version/0/assignee/219/author/219/status/current/order/date/group/status/editid/0/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)