using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<child\s+[^<]*?attr2=[\'\""](?<value>[^<]*?)[\'\""]";
string substitution = @"";
string input = @"Correct Matched:
<child attr1='1' attr2='asd asddsa' attr3='1'/>
<child attr1='1' attr2='asd asddsa'attr3='1'/>
<child attr1='1' attr2='asd asddsa' />
<child attr1='1' attr2='asd asddsa'/>
<child attr1='1' attr2='asd
asddsa'/>
<child attr1='1' attr2='asd asddsa'></child>
<child attr1='1""'' attr2='asd asddsa'><elem/></child>
<child attr1='1sda-cxc""'asdcvas<' elem attr2='asd asddsa' attr1=1><elem/></child'>
<child attr1='1sda-cxc""'asdcvas<'
elem attr2='asd asddsa' attr1=1><elem/></child
</root>
Correctly Not Matched:
<child attr1='1sda-cxc""'asdcvas'><elem attr2='asd asddsa' attr1=1><elem/></child>
Bug:
<child attr1='1sda-cxc""'asdcvas'> elem attr2='asd asddsa' attr1=1><elem/></child>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}