const regex = /<child\s+[^<]*?attr2=[\'\"](?<value>[^<]*?)[\'\"]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<child\\s+[^<]*?attr2=[\\\'\\"](?<value>[^<]*?)[\\\'\\"]', 'g')
const str = `Correct Matched:
<child attr1='1' attr2='asd asddsa' attr3='1'/>
<child attr1='1' attr2='asd asddsa'attr3='1'/>
<child attr1='1' attr2='asd asddsa' />
<child attr1='1' attr2='asd asddsa'/>
<child attr1='1' attr2='asd
asddsa'/>
<child attr1='1' attr2='asd asddsa'></child>
<child attr1='1"'' attr2='asd asddsa'><elem/></child>
<child attr1='1sda-cxc"'asdcvas<' elem attr2='asd asddsa' attr1=1><elem/></child'>
<child attr1='1sda-cxc"'asdcvas<'
elem attr2='asd asddsa' attr1=1><elem/></child
</root>
Correctly Not Matched:
<child attr1='1sda-cxc"'asdcvas'><elem attr2='asd asddsa' attr1=1><elem/></child>
Bug:
<child attr1='1sda-cxc"'asdcvas'> elem attr2='asd asddsa' attr1=1><elem/></child>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);