package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<child\s+[^<]*?attr2=[\'\"](?<value>[^<]*?)[\'\"]`)
var str = `Correct Matched:
<child attr1='1' attr2='asd asddsa' attr3='1'/>
<child attr1='1' attr2='asd asddsa'attr3='1'/>
<child attr1='1' attr2='asd asddsa' />
<child attr1='1' attr2='asd asddsa'/>
<child attr1='1' attr2='asd
asddsa'/>
<child attr1='1' attr2='asd asddsa'></child>
<child attr1='1"'' attr2='asd asddsa'><elem/></child>
<child attr1='1sda-cxc"'asdcvas<' elem attr2='asd asddsa' attr1=1><elem/></child'>
<child attr1='1sda-cxc"'asdcvas<'
elem attr2='asd asddsa' attr1=1><elem/></child
</root>
Correctly Not Matched:
<child attr1='1sda-cxc"'asdcvas'><elem attr2='asd asddsa' attr1=1><elem/></child>
Bug:
<child attr1='1sda-cxc"'asdcvas'> elem attr2='asd asddsa' attr1=1><elem/></child>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}