import Foundation
let pattern = #"<child\s+[^<]*?attr2=[\'\"](?<value>[^<]*?)[\'\"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Correct Matched:
<child attr1='1' attr2='asd asddsa' attr3='1'/>
<child attr1='1' attr2='asd asddsa'attr3='1'/>
<child attr1='1' attr2='asd asddsa' />
<child attr1='1' attr2='asd asddsa'/>
<child attr1='1' attr2='asd
asddsa'/>
<child attr1='1' attr2='asd asddsa'></child>
<child attr1='1"'' attr2='asd asddsa'><elem/></child>
<child attr1='1sda-cxc"'asdcvas<' elem attr2='asd asddsa' attr1=1><elem/></child'>
<child attr1='1sda-cxc"'asdcvas<'
elem attr2='asd asddsa' attr1=1><elem/></child
</root>
Correctly Not Matched:
<child attr1='1sda-cxc"'asdcvas'><elem attr2='asd asddsa' attr1=1><elem/></child>
Bug:
<child attr1='1sda-cxc"'asdcvas'> elem attr2='asd asddsa' attr1=1><elem/></child>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)