package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\[(?P<link>[^\s]+)\s(?P<text>[^\]]+)\]\]`)
var str = `[[http://www.example.com/path/to/file.ext "click here"]]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}