const regex = /\[\[(?P<link>[^\s]+)\s(?P<text>[^\]]+)\]\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[(?P<link>[^\\s]+)\\s(?P<text>[^\\]]+)\\]\\]', '')
const str = `[[http://www.example.com/path/to/file.ext "click here"]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}