$re = '/\[\[(?P<link>[^\s]+)\s(?P<text>[^\]]+)\]\]/';
$str = '[[http://www.example.com/path/to/file.ext "click here"]]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);