re = /\[\[(?P<link>[^\s]+)\s(?P<text>[^\]]+)\]\]/
str = '[[http://www.example.com/path/to/file.ext "click here"]]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end