#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9a-zA-Z][\w\.]*)(?<=[0-9a-zA-Z])@([\w]+)\.com$"
Local $sString = "xyz.@test.com" & @CRLF & _
".xyz@test.com" & @CRLF & _
"xy.z@test.com" & @CRLF & _
"x@test.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")