using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9a-zA-Z][\w\.]*)(?<=[0-9a-zA-Z])@([\w]+)\.com$";
string input = @"xyz.@test.com
.xyz@test.com
xy.z@test.com
x@test.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}