$re = '/^([0-9a-zA-Z][\w\.]*)(?<=[0-9a-zA-Z])@([\w]+)\.com$/m';
$str = 'xyz.@test.com
.xyz@test.com
xy.z@test.com
x@test.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);