import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9a-zA-Z][\\w\\.]*)(?<=[0-9a-zA-Z])@([\\w]+)\\.com$";
final String string = "xyz.@test.com\n"
+ ".xyz@test.com\n"
+ "xy.z@test.com\n"
+ "x@test.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}