#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Z][a-z]+(?: [A-Z][a-z]+\b(?!-))+(?: [A-Z][a-z]+-[A-Z][a-z]+)?|(?:[A-Z][a-z]+ )?[A-Z][a-z]+-[A-Z][a-z]+)$"
Local $sString = "Apple Banana Couonut-Dates" & @CRLF & _
"Apple Banana Test Couonut-Dates" & @CRLF & _
"Apple Banana" & @CRLF & _
"Banana Couonut-Dates" & @CRLF & _
"Couonut-Dates" & @CRLF & _
"" & @CRLF & _
"Apple" & @CRLF & _
"Apple Banana Couonut-dates" & @CRLF & _
"BanAna couonut-Dates"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")