import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Z][a-z]+(?: [A-Z][a-z]+\\b(?!-))+(?: [A-Z][a-z]+-[A-Z][a-z]+)?|(?:[A-Z][a-z]+ )?[A-Z][a-z]+-[A-Z][a-z]+)$";
final String string = "Apple Banana Couonut-Dates\n"
+ "Apple Banana Test Couonut-Dates\n"
+ "Apple Banana\n"
+ "Banana Couonut-Dates\n"
+ "Couonut-Dates\n\n"
+ "Apple\n"
+ "Apple Banana Couonut-dates\n"
+ "BanAna couonut-Dates";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}