re = /^(?:[A-Z][a-z]+(?: [A-Z][a-z]+\b(?!-))+(?: [A-Z][a-z]+-[A-Z][a-z]+)?|(?:[A-Z][a-z]+ )?[A-Z][a-z]+-[A-Z][a-z]+)$/m
str = 'Apple Banana Couonut-Dates
Apple Banana Test Couonut-Dates
Apple Banana
Banana Couonut-Dates
Couonut-Dates
Apple
Apple Banana Couonut-dates
BanAna couonut-Dates'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end